Announcement

Collapse
No announcement yet.

Morningstar PS MPPT 40M Controller Issue

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Morningstar PS MPPT 40M Controller Issue

    I recently purchased this charge controller from Morningstar. It fits my needs just fine and allows me room to grow. After 8 days the meter screen and control buttons froze up and required a reset to clear. Charging functions were still working just no screen or control buttons. After two days it did it again. Contacted Morningstar support and they answered immediatly. Great customer service at Morningstar, no doubt and a very well built product they make.

    They informed me it is a known bug and they are working on a fix. Fair enough but it makes me wonder how a controller that has been on the market for 3 years has this issue and I never heard of it in my research for a controller. Dont get me wrong I am going to wait for a firmware release to fix it and I am on their email list to be notified when it is out. I know Morningstar is one of the best so I will stay with them but it is a major bug to just have it lock up all the time and for it to have been years in the code. Unless a firmware release introduced it I have to assume it's been there since the first one was sold and if firmware did release it seems it could be rolled back to remove the issue.

    Anyone that can shed any light on this bug or anyone ever hear of it? I found nothing at all online about it.

  • #2
    Originally posted by JMMSUN View Post
    I recently purchased this charge controller from Morningstar. It fits my needs just fine and allows me room to grow. After 8 days the meter screen and control buttons froze up and required a reset to clear. Charging functions were still working just no screen or control buttons. After two days it did it again. Contacted Morningstar support and they answered immediatly. Great customer service at Morningstar, no doubt and a very well built product they make.

    They informed me it is a known bug and they are working on a fix. Fair enough but it makes me wonder how a controller that has been on the market for 3 years has this issue and I never heard of it in my research for a controller. Dont get me wrong I am going to wait for a firmware release to fix it and I am on their email list to be notified when it is out. I know Morningstar is one of the best so I will stay with them but it is a major bug to just have it lock up all the time and for it to have been years in the code. Unless a firmware release introduced it I have to assume it's been there since the first one was sold and if firmware did release it seems it could be rolled back to remove the issue.

    Anyone that can shed any light on this bug or anyone ever hear of it? I found nothing at all online about it.
    This might be A-Work-Around use wi-fi bridge with web based app to see and control thru RJ11 port

    ether.png buss.png
    Last edited by Paul Land; 12-23-2018, 11:55 AM.

    Comment


    • #3
      Thanks for the suggestion. I have looked at some of the alternative Com solutions but they are very expensive. Right now I am over $600 into this controller and the USB firmware MSCom cable they sell which I need to push firmware when it's available. It locked up again overnight. Frustrating....

      Comment


      • #4
        How does this make it "one of the best"?

        Comment


        • #5
          Originally posted by cholmes100 View Post
          How does this make it "one of the best"?
          Not sure it does Holmes....but thanks for your input.

          Comment


          • #6
            Bummer. I've liked the MPPT - 60 with it's built in web interface. You still need a $10 serial RS23 cable to upload settings or firmware.
            Powerfab top of pole PV mount (2) | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
            || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
            || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

            solar: http://tinyurl.com/LMR-Solar
            gen: http://tinyurl.com/LMR-Lister

            Comment


            • #7
              Originally posted by Mike90250 View Post
              Bummer. I've liked the MPPT - 60 with it's built in web interface. You still need a $10 serial RS23 cable to upload settings or firmware.
              Yeah I almost got the TriStar MPPT 45 but got this one instead. On a bright note, Morningstar offered me a full replacement solution at no cost to me. I took them up on it and will move on. They seem to be a great company and this bug was just one that bit me.

              Comment

              Working...
              X