No announcement yet.

Off grid solar controller not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Off grid solar controller not working

    I have 4 220ah batteries (6v in series and parallel =12v system) controlled with 2 mppt charge controller with 800 watts solar panels. My one CC mppt 40amp controller stop charging my batteries. I tried many different things, like a different solar panel, new battery cable... But nothing will work. The controller is doing everything except not turn on the solar charging light on the CC.

    I think I figured out what is going on. When I connect just the solar panel to THE CC the voltage shows approximately 33 volts (my panels voltage) however when I connect the panel and battery to the CC it drops the panels voltage to 12.4 on the CC. So I think the CC thinks the battery's are not wanting a charge. I think is has something to do with the over discharge or over discharge return voltage. Does anyone have any suggestions

  • #2
    What is the model/make of your charge controller?


    • #3
      Often when you have a PWM and MPPT controllers on one battery bank, the PWM confuses the smart MPPT controller with it's pulses. Or you have a counterfeit MPPT controller.

      You also must make sure the controllers connect first to the battery, and are allowed to boot up. After they boot up, you can then apply the PV power lines. A controller connected to PV only and no battery, can be fried quickly, being without a battery to sink 95V or whatever is coming out of your panel array.

      Powerfab top of pole PV mount (2) | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
      || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
      || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A



      • #4
        Both are mttp SRNE solar controller, the first controller is a 40 amp (the broken one) and the second is a 30amp. I have had them for over two years. I did connect the battery first then panel. However it was not working so I tried the panel first. Anyways I think the controller is broken. Thanks for the info